import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{11}|\\d{3}-\\d{8})";
final String string = "222-22222222\n"
+ "22222222222\n"
+ "22222\n"
+ "222224452=222\n"
+ "223-22222222\n"
+ "11111111111\n"
+ "SAAAAAAAAAA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}