$re = '/(\d{11}|\d{3}-\d{8})/m';
$str = '222-22222222
22222222222
22222
222224452=222
223-22222222
11111111111
SAAAAAAAAAA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);