#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(^(?=.*[0-9])(?=.*[A-Z])(?=.*[a-z])|(^(?=.*[0-9])(?=.*[A-Z])(?=.*[!@#$&*]).*$)|(^(?=.*[0-9])(?=.*[a-z])(?=.*[!@#$&*]).*$)|(?=.*[A-Z])(?=.*[a-z])(?=.*[!@#$&*]).*$).*$"
Local $sString = "1" & @CRLF & _
"A" & @CRLF & _
"a" & @CRLF & _
"#" & @CRLF & _
"111" & @CRLF & _
"AAA" & @CRLF & _
"aaa" & @CRLF & _
"###" & @CRLF & _
"11a" & @CRLF & _
"11A" & @CRLF & _
"11a" & @CRLF & _
"11#" & @CRLF & _
"1A1" & @CRLF & _
"1AA" & @CRLF & _
"1Aa" & @CRLF & _
"1A#" & @CRLF & _
"A1a" & @CRLF & _
"aA1" & @CRLF & _
"1A#" & @CRLF & _
"A#1" & @CRLF & _
"#A1" & @CRLF & _
"1a#" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")