import Foundation
let pattern = ##"^(^(?=.*[0-9])(?=.*[A-Z])(?=.*[a-z])|(^(?=.*[0-9])(?=.*[A-Z])(?=.*[!@#$&*]).*$)|(^(?=.*[0-9])(?=.*[a-z])(?=.*[!@#$&*]).*$)|(?=.*[A-Z])(?=.*[a-z])(?=.*[!@#$&*]).*$).*$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ####"""
1
A
a
#
111
AAA
aaa
###
11a
11A
11a
11#
1A1
1AA
1Aa
1A#
A1a
aA1
1A#
A#1
#A1
1a#
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)