use strict;
my $str = '1
A
a
#
111
AAA
aaa
###
11a
11A
11a
11#
1A1
1AA
1Aa
1A#
A1a
aA1
1A#
A#1
#A1
1a#
';
my $regex = qr/^(^(?=.*[0-9])(?=.*[A-Z])(?=.*[a-z])|(^(?=.*[0-9])(?=.*[A-Z])(?=.*[!@#$&*]).*$)|(^(?=.*[0-9])(?=.*[a-z])(?=.*[!@#$&*]).*$)|(?=.*[A-Z])(?=.*[a-z])(?=.*[!@#$&*]).*$).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}