import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(^(?=.*[0-9])(?=.*[A-Z])(?=.*[a-z])|(^(?=.*[0-9])(?=.*[A-Z])(?=.*[!@#$&*]).*$)|(^(?=.*[0-9])(?=.*[a-z])(?=.*[!@#$&*]).*$)|(?=.*[A-Z])(?=.*[a-z])(?=.*[!@#$&*]).*$).*$";
final String string = "1\n"
+ "A\n"
+ "a\n"
+ "#\n"
+ "111\n"
+ "AAA\n"
+ "aaa\n"
+ "###\n"
+ "11a\n"
+ "11A\n"
+ "11a\n"
+ "11#\n"
+ "1A1\n"
+ "1AA\n"
+ "1Aa\n"
+ "1A#\n"
+ "A1a\n"
+ "aA1\n"
+ "1A#\n"
+ "A#1\n"
+ "#A1\n"
+ "1a#\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}