#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\/)(?=[\w-+=\s]+[0-9])[\w-+=\s]{7,}(?![.])(?!\.)(?=\/|\n)"
Local $sString = "/test/ajs1d5haFkajs1dhasdd2as345sdAS3+Ddas9" & @CRLF & _
"/test/akKd9Ja3/ajs1d5haFkajs1ddasd623ha5sdAS3Ddas9=/30" & @CRLF & _
"/test/akKd9Ja3/Example-ASDAdddasd-108174.js" & @CRLF & _
"/test/akKd9Ja3-ASj83asj-dask92qwe_ke" & @CRLF & _
"/filestreamingservice/as88ASD8asd" & @CRLF & _
"/graphic_new/asdasAD7afasfa" & @CRLF & _
"/isthis working12/" & @CRLF & _
"/123abcdef/" & @CRLF & _
"/abcdefghr/" & @CRLF & _
""
Local $sSubst = "<random>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)