using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\/)(?=[\w-+=\s]+[0-9])[\w-+=\s]{7,}(?![.])(?!\.)(?=\/|\n)";
string substitution = @"<random>";
string input = @"/test/ajs1d5haFkajs1dhasdd2as345sdAS3+Ddas9
/test/akKd9Ja3/ajs1d5haFkajs1ddasd623ha5sdAS3Ddas9=/30
/test/akKd9Ja3/Example-ASDAdddasd-108174.js
/test/akKd9Ja3-ASj83asj-dask92qwe_ke
/filestreamingservice/as88ASD8asd
/graphic_new/asdasAD7afasfa
/isthis working12/
/123abcdef/
/abcdefghr/
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}