use strict;
my $str = '/test/ajs1d5haFkajs1dhasdd2as345sdAS3+Ddas9
/test/akKd9Ja3/ajs1d5haFkajs1ddasd623ha5sdAS3Ddas9=/30
/test/akKd9Ja3/Example-ASDAdddasd-108174.js
/test/akKd9Ja3-ASj83asj-dask92qwe_ke
/filestreamingservice/as88ASD8asd
/graphic_new/asdasAD7afasfa
/isthis working12/
/123abcdef/
/abcdefghr/
';
my $regex = qr/(?<=\/)(?=[\w-+=\s]+[0-9])[\w-+=\s]{7,}(?![.])(?!\.)(?=\/|\n)/mp;
my $subst = '<random>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";