# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\/)(?=[\w-+=\s]+[0-9])[\w-+=\s]{7,}(?![.])(?!\.)(?=\/|\n)"
test_str = ("/test/ajs1d5haFkajs1dhasdd2as345sdAS3+Ddas9\n"
"/test/akKd9Ja3/ajs1d5haFkajs1ddasd623ha5sdAS3Ddas9=/30\n"
"/test/akKd9Ja3/Example-ASDAdddasd-108174.js\n"
"/test/akKd9Ja3-ASj83asj-dask92qwe_ke\n"
"/filestreamingservice/as88ASD8asd\n"
"/graphic_new/asdasAD7afasfa\n"
"/isthis working12/\n"
"/123abcdef/\n"
"/abcdefghr/\n")
subst = "<random>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.