using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(проезд|пл|пр-кт|пер|наб|линия|км|б-р|аллея|кв-л)(?!.*\)$)\s*(.+)$";
string input = @"проезд Волокойёламский Большой
аллея 11-ти Героев Сапёров
аллея Беговая
аллея Берёзовая (ЗелАО)
б-р Большой (тер. ИЦ «Сколково»)
б-р Волжский
кв-л Самаркандский бульв., 134а
км МКАД 100-й
линия Савёловская
линия Северная 1-я
линия Хорошёвского Серебряного Бора 1-я
наб Крутицкая
пер 800-летия Москвы
пер Абрикосовский
пер Богородский 2-й (г. Троицк)
пл 60-летия СССР
пл Абельмановская Застава
пр-кт 60-летия Октября (пос. Абабурово)
пр-кт Академика Сахарова
пр-кт Андропова
проезд Академический
проезд Александровский (дер. Зверево)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}