# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(проезд|пл|пр-кт|пер|наб|линия|км|б-р|аллея|кв-л)(?!.*\)$)\s*(.+)$"
test_str = ("проезд Волокойёламский Большой\n"
"аллея 11-ти Героев Сапёров\n"
"аллея Беговая\n"
"аллея Берёзовая (ЗелАО)\n"
"б-р Большой (тер. ИЦ «Сколково»)\n"
"б-р Волжский\n"
"кв-л Самаркандский бульв., 134а\n"
"км МКАД 100-й\n"
"линия Савёловская\n"
"линия Северная 1-я\n"
"линия Хорошёвского Серебряного Бора 1-я\n"
"наб Крутицкая\n"
"пер 800-летия Москвы\n"
"пер Абрикосовский\n"
"пер Богородский 2-й (г. Троицк)\n"
"пл 60-летия СССР\n"
"пл Абельмановская Застава\n"
"пр-кт 60-летия Октября (пос. Абабурово)\n"
"пр-кт Академика Сахарова\n"
"пр-кт Андропова\n"
"проезд Академический\n"
"проезд Александровский (дер. Зверево)\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.