import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(проезд|пл|пр-кт|пер|наб|линия|км|б-р|аллея|кв-л)(?!.*\\)$)\\s*(.+)$";
final String string = "проезд Волокойёламский Большой\n"
+ "аллея 11-ти Героев Сапёров\n"
+ "аллея Беговая\n"
+ "аллея Берёзовая (ЗелАО)\n"
+ "б-р Большой (тер. ИЦ «Сколково»)\n"
+ "б-р Волжский\n"
+ "кв-л Самаркандский бульв., 134а\n"
+ "км МКАД 100-й\n"
+ "линия Савёловская\n"
+ "линия Северная 1-я\n"
+ "линия Хорошёвского Серебряного Бора 1-я\n"
+ "наб Крутицкая\n"
+ "пер 800-летия Москвы\n"
+ "пер Абрикосовский\n"
+ "пер Богородский 2-й (г. Троицк)\n"
+ "пл 60-летия СССР\n"
+ "пл Абельмановская Застава\n"
+ "пр-кт 60-летия Октября (пос. Абабурово)\n"
+ "пр-кт Академика Сахарова\n"
+ "пр-кт Андропова\n"
+ "проезд Академический\n"
+ "проезд Александровский (дер. Зверево)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}