import Foundation
let pattern = #"^(проезд|пл|пр-кт|пер|наб|линия|км|б-р|аллея|кв-л)(?!.*\)$)\s*(.+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
проезд Волокойёламский Большой
аллея 11-ти Героев Сапёров
аллея Беговая
аллея Берёзовая (ЗелАО)
б-р Большой (тер. ИЦ «Сколково»)
б-р Волжский
кв-л Самаркандский бульв., 134а
км МКАД 100-й
линия Савёловская
линия Северная 1-я
линия Хорошёвского Серебряного Бора 1-я
наб Крутицкая
пер 800-летия Москвы
пер Абрикосовский
пер Богородский 2-й (г. Троицк)
пл 60-летия СССР
пл Абельмановская Застава
пр-кт 60-летия Октября (пос. Абабурово)
пр-кт Академика Сахарова
пр-кт Андропова
проезд Академический
проезд Александровский (дер. Зверево)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)