import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\()?(?P<area>\\d{3})(?(1)\\))[ -]?(?P<fst>\\d{3})-?(?P<lst>\\d{4})$";
final String string = "(321) 123-4567\n"
+ "(321) 1234567\n"
+ "321-123-4567\n"
+ "321123-4567";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}