const regex = /^(\()?(?P<area>\d{3})(?(1)\))[ -]?(?P<fst>\d{3})-?(?P<lst>\d{4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\()?(?P<area>\\d{3})(?(1)\\))[ -]?(?P<fst>\\d{3})-?(?P<lst>\\d{4})$', 'gm')
const str = `(321) 123-4567
(321) 1234567
321-123-4567
321123-4567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}