re = /^(\()?(?P<area>\d{3})(?(1)\))[ -]?(?P<fst>\d{3})-?(?P<lst>\d{4})$/m
str = '(321) 123-4567
(321) 1234567
321-123-4567
321123-4567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end