package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[0-9]{1,3}\.){1,3}[0-9]{1,3}`)
var str = `192.168.10.1
10.5.6.7
234.4.5.6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}