$re = '/(?:[0-9]{1,3}\.){1,3}[0-9]{1,3}/m';
$str = '192.168.10.1
10.5.6.7
234.4.5.6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);