import re
regex = re.compile(r"(?:[0-9]{1,3}\.){1,3}[0-9]{1,3}", flags=re.MULTILINE)
test_str = ("192.168.10.1\n"
"10.5.6.7\n"
"234.4.5.6")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")