using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[/\S+/]+[\\.][/\S+/]+";
string input = @"teste.teste
teste1*$&.teste1589
teste1*$a.1teste1589
teste
teste.
.bla";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}