package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[/\S+/]+[\\.][/\S+/]+`)
var str = `teste.teste
teste1*$&.teste1589
teste1*$a.1teste1589
teste
teste.
.bla`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}