re = /[\/\S+\/]+[\\.][\/\S+\/]+/i
str = 'teste.teste
teste1*$&.teste1589
teste1*$a.1teste1589
teste
teste.
.bla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end