import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[/\\S+/]+[\\\\.][/\\S+/]+";
final String string = "teste.teste\n"
+ "teste1*$&.teste1589\n"
+ "teste1*$a.1teste1589\n"
+ "teste\n"
+ "teste.\n"
+ ".bla";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}