# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G\B|\b(?=\w{50}))\w{10}\B\K/ /gm;t' <<< "foobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoo"