import Foundation
let pattern = #"(?:\G\B|\b(?=\w{50}))\w{10}\B\K"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"foobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoo"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)