using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G\B|\b(?=\w{50}))\w{10}\B\K";
string substitution = @" ";
string input = @"foobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoo";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}