$re = '/(?:\G\B|\b(?=\w{50}))\w{10}\B\K/m';
$str = 'foobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoofoobarbarfoo foobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoofoobarbarfoo';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;