#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9]{1,2}(\.[0-9]{1,2})*)-([0-9]{1,2}(\.[0-9]{1,2})*)[%]*"
Local $sString = "6-9" & @CRLF & _
"6.5-9" & @CRLF & _
"6-9.24" & @CRLF & _
"6-9%" & @CRLF & _
"6.5-9%" & @CRLF & _
"6.24-9.23%" & @CRLF & _
"6" & @CRLF & _
"6.1" & @CRLF & _
"6-" & @CRLF & _
"6.1-" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")