re = /([0-9]{1,2}(\.[0-9]{1,2})*)-([0-9]{1,2}(\.[0-9]{1,2})*)[%]*/m
str = '6-9
6.5-9
6-9.24
6-9%
6.5-9%
6.24-9.23%
6
6.1
6-
6.1-
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end