$re = '/([0-9]{1,2}(\.[0-9]{1,2})*)-([0-9]{1,2}(\.[0-9]{1,2})*)[%]*/m';
$str = '6-9
6.5-9
6-9.24
6-9%
6.5-9%
6.24-9.23%
6
6.1
6-
6.1-
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);