import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{1,2}(\\.[0-9]{1,2})*)-([0-9]{1,2}(\\.[0-9]{1,2})*)[%]*";
final String string = "6-9\n"
+ "6.5-9\n"
+ "6-9.24\n"
+ "6-9%\n"
+ "6.5-9%\n"
+ "6.24-9.23%\n"
+ "6\n"
+ "6.1\n"
+ "6-\n"
+ "6.1-\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}