import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(.*\\) ?(?:: (.+))?";
final String string = " + Update () : void\n\n"
+ " + KeyPress (key : int) : bool\n"
+ " + KeyRelease (key : int) : bool\n"
+ " + IsKeyDown (key : int) : bool\n\n"
+ " + MousePress (button : int) : bool\n"
+ " + MouseRelease (button : int) : bool\n"
+ " + IsMouseDown (button : int) : bool\n\n"
+ " + GetMouseX () : int\n"
+ " + GetMouseY () : int\n\n"
+ " + QuitRequested () : bool\n\n"
+ " + GetInstance () : InputManager&\n\n"
+ " - InputManager ()\n"
+ " - ~InputManager ()\n\n\n"
+ " - mouseState : bool[6]\n"
+ " - mouseUpdate : int[6]\n\n"
+ " - keyState : ler abaixo\n"
+ " - keyUpdate : ler abaixo\n\n"
+ " - quitRequested : bool\n\n"
+ " - updateCounter : int\n\n"
+ " - mouseX : int\n"
+ " - mouseY : int\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}