const regex = /\(.*\) ?(?:: (.+))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(.*\\) ?(?:: (.+))?', 'gm')
const str = ` + Update () : void
+ KeyPress (key : int) : bool
+ KeyRelease (key : int) : bool
+ IsKeyDown (key : int) : bool
+ MousePress (button : int) : bool
+ MouseRelease (button : int) : bool
+ IsMouseDown (button : int) : bool
+ GetMouseX () : int
+ GetMouseY () : int
+ QuitRequested () : bool
+ GetInstance () : InputManager&
- InputManager ()
- ~InputManager ()
- mouseState : bool[6]
- mouseUpdate : int[6]
- keyState : ler abaixo
- keyUpdate : ler abaixo
- quitRequested : bool
- updateCounter : int
- mouseX : int
- mouseY : int
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}