// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(.*\) ?(?:: (.+))?").unwrap();
let string = " + Update () : void
+ KeyPress (key : int) : bool
+ KeyRelease (key : int) : bool
+ IsKeyDown (key : int) : bool
+ MousePress (button : int) : bool
+ MouseRelease (button : int) : bool
+ IsMouseDown (button : int) : bool
+ GetMouseX () : int
+ GetMouseY () : int
+ QuitRequested () : bool
+ GetInstance () : InputManager&
- InputManager ()
- ~InputManager ()
- mouseState : bool[6]
- mouseUpdate : int[6]
- keyState : ler abaixo
- keyUpdate : ler abaixo
- quitRequested : bool
- updateCounter : int
- mouseX : int
- mouseY : int
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}