$re = '/^([a-z0-9]+((?=\..+@.+\..+)[a-z0-9.]*@[a-z0-9]*\.[a-z0-9]*))$/mi';
$str = 'nagarjuna.nag@vm.com
nagarjuna12.nag@vm.com
nagarjuna12.nag.some@vm.com
nagarjuna12.nag.somenagarjuna12.nag.some@vm.com
nagarjuna12.nag.somenagarjuna12.nag.some@vm.co.uk
a.b@a.c
1.2@3.4
-.-@-.-
...@a.c
.@a.c
..@....
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);