import re
regex = re.compile(r"^([a-z0-9]+((?=\..+@.+\..+)[a-z0-9.]*@[a-z0-9]*\.[a-z0-9]*))$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("nagarjuna.nag@vm.com\n"
"nagarjuna12.nag@vm.com\n"
"nagarjuna12.nag.some@vm.com\n"
"nagarjuna12.nag.somenagarjuna12.nag.some@vm.com\n"
"nagarjuna12.nag.somenagarjuna12.nag.some@vm.co.uk\n"
"a.b@a.c\n"
"1.2@3.4\n"
"-.-@-.-\n"
"...@a.c\n"
".@a.c\n"
"..@....\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")