re = /^([a-z0-9]+((?=\..+@.+\..+)[a-z0-9.]*@[a-z0-9]*\.[a-z0-9]*))$/mi
str = 'nagarjuna.nag@vm.com
nagarjuna12.nag@vm.com
nagarjuna12.nag.some@vm.com
nagarjuna12.nag.somenagarjuna12.nag.some@vm.com
nagarjuna12.nag.somenagarjuna12.nag.some@vm.co.uk
a.b@a.c
1.2@3.4
-.-@-.-
...@a.c
.@a.c
..@....
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end