using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a(?: .+?)?>.*?<\/a>";
string input = @"<address><a href=”/home”>ホーム</a></address><a href=”/page”>ページ</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}