$re = '/<a(?: .+?)?>.*?<\/a>/';
$str = '<address><a href=”/home”>ホーム</a></address><a href=”/page”>ページ</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);