re = /<a(?: .+?)?>.*?<\/a>/
str = '<address><a href=”/home”>ホーム</a></address><a href=”/page”>ページ</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end