package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a(?: .+?)?>.*?<\/a>`)
var str = `<address><a href=”/home”>ホーム</a></address><a href=”/page”>ページ</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}