import re
regex = re.compile(r"^(.*?)/(.*?),now\s(.*?)\s(.*?)\s")
test_str = ("usbmuxd/kali-rolling,now 1.1.0-2+b1 amd64 [installed,automatic]\n"
"usbutils/kali-rolling,now 1:007-4 amd64 [installed]\n"
"util-linux/kali-rolling,now 2.28-6 amd64 [installed]\n"
"uuid-runtime/kali-rolling,now 2.28-6 amd64 [installed,automatic]\n"
"va-driver-all/kali-rolling,now 1.7.1-2 amd64 [installed,automatic]\n"
"vboot-kernel-utils/kali-rolling,now 0~R52-8350.B-1 amd64 [installed,automatic]\n"
"vboot-utils/kali-rolling,now 0~R52-8350.B-1 amd64 [installed,automatic]\n"
"vdpau-driver-all/kali-rolling,now 1.1.1-3 amd64 [installed,automatic]\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")