#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:https?:\/\/)?(?:www\.)?facebook\.com\/?$"
Local $sString = "facebook.com/username" & @CRLF & _
"www.facebook.com/username" & @CRLF & _
"http://facebook.com/username" & @CRLF & _
"http://www.facebook.com/username" & @CRLF & _
"https://facebook.com/username" & @CRLF & _
"https://www.facebook.com/username" & @CRLF & _
"" & @CRLF & _
"facebook.com" & @CRLF & _
"facebook.com/" & @CRLF & _
"....................." & @CRLF & _
"https://facebook.com/" & @CRLF & _
"https://www.facebook.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")