$re = '/^(?:https?:\/\/)?(?:www\.)?facebook\.com\/?$/im';
$str = 'facebook.com/username
www.facebook.com/username
http://facebook.com/username
http://www.facebook.com/username
https://facebook.com/username
https://www.facebook.com/username
facebook.com
facebook.com/
.....................
https://facebook.com/
https://www.facebook.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);