re = /^(?:https?:\/\/)?(?:www\.)?facebook\.com\/?$/im
str = 'facebook.com/username
www.facebook.com/username
http://facebook.com/username
http://www.facebook.com/username
https://facebook.com/username
https://www.facebook.com/username
facebook.com
facebook.com/
.....................
https://facebook.com/
https://www.facebook.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end