import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?(?:www\\.)?facebook\\.com\\/?$";
final String string = "facebook.com/username\n"
+ "www.facebook.com/username\n"
+ "http://facebook.com/username\n"
+ "http://www.facebook.com/username\n"
+ "https://facebook.com/username\n"
+ "https://www.facebook.com/username\n\n"
+ "facebook.com\n"
+ "facebook.com/\n"
+ ".....................\n"
+ "https://facebook.com/\n"
+ "https://www.facebook.com";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}