// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\/\d{2}( \d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})?(, \d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\/\d{2}( \d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})?)*$").unwrap();
let string = "213.233.34.12/30 1.2.3.4, 213.233.34.12/30 1.2.3.4";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}