#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)DeviceXYZ.+$"
Local $sString = "Building1-Lab1-DeviceABC1" & @CRLF & _
"Building1-Lab1-DeviceABC2" & @CRLF & _
"Building1-Lab1-DeviceXYZ1" & @CRLF & _
"" & @CRLF & _
"Building1-Lab2-DeviceABC1" & @CRLF & _
"Building1-Lab2-DeviceABC2" & @CRLF & _
"Building1-Lab2-DeviceXYZ1" & @CRLF & _
"" & @CRLF & _
"Building2-Lab1-DeviceABC1" & @CRLF & _
"Building2-Lab1-DeviceABC2" & @CRLF & _
"Building2-Lab1-DeviceXYZ1" & @CRLF & _
"" & @CRLF & _
"Building2-Lab2-DeviceABC1" & @CRLF & _
"Building2-Lab2-DeviceABC2" & @CRLF & _
"Building2-Lab2-DeviceXYZ1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")