re = /DeviceXYZ.+$/m
str = 'Building1-Lab1-DeviceABC1
Building1-Lab1-DeviceABC2
Building1-Lab1-DeviceXYZ1
Building1-Lab2-DeviceABC1
Building1-Lab2-DeviceABC2
Building1-Lab2-DeviceXYZ1
Building2-Lab1-DeviceABC1
Building2-Lab1-DeviceABC2
Building2-Lab1-DeviceXYZ1
Building2-Lab2-DeviceABC1
Building2-Lab2-DeviceABC2
Building2-Lab2-DeviceXYZ1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end